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End Users License Agreement

FOR QuickEdgeTM Version 2.49.0 Software Product

KARTHAVYA LICENSES THIS QUICKEDGE SOFTWARE PRODUCT TO YOU SUBJECT TO THE TERMS CONTAINED IN THIS END
USER LICENSE AGREEMENT ("EULA"). READ THE TERMS OF THIS EULA CAREFULLY. BY INSTALLING, COPYING OR OTHERWISE
USING THE SOFTWARE (AS DEFINED BELOW), YOU AGREE TO BE BOUND BY THE TERMS OF THIS EULA.IF YOU DO NOT
AGREE TO THE TERMS OF THIS EULA, DO NOT INSTALL, COPY OR USE THE SOFTWARE.

NOTICE TO CUSTOMER

If you do not agree to the terms of this EULA, do not install, or use this software. This EULA is a contract between you
(either an individual or an entity) and KARTHAVYA which governs your use of this KARTHAVYA software product that
accompanies this EULA and related software components, which may include the associated programs, explanatory
materials and the supporting documentation.

LICENCE GRANT

KARTHAVYA grants you a license to use one copy of the Software. Each License purchased allows you to install 1 copy of
the license. "Use" means storing, loading, installing and executing. You agree to use all reasonable efforts to protect the
Product from unauthorized use, reproduction, distribution or publication. You may not modify the Software or disable any
licensing or control features of the Software in any manner without prior written permission by KARTHAVYA.

LICENSE LIMITATIONS

You may not copy the Software except for a reasonable number of machine-readable copies of the software for backup or
archival purposes and except as expressly permitted in the License Grant section above. You may not remove any titles,
trademarks or trade names, copyright notices, legends, or other proprietary markings on the Software. You are not granted
any rights to any trademarks or service marks of KARTHAVYA. KARTHAVYA retains all rights not expressly granted to you.

CONTACT INFORMATION

If you have any questions about this EULA, or if you want to contact KARTHAVYA for any reason, please send email directly
to: support@karthavya.com
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1.Preface

Congratulations on the purchase of QUICKEDGE MAM & Archival System. QUICKEDGE streamlines the media management
workflow, along with DataHeart/Gravity deep HSM gateway provides you a one stop destination for media management of
both online, nearline and offline storage solutions. QuickEdge integrates with the following storage types seamlessly: NAS,
SAN, DAS, LTO, ODA and Cloud.

1.1 Who should use this user manual

This manual is written for librarians, video editors and various technical personnel responsible for using the QUICKEDGE
MAM & Archival in a media workflow. Portions of the manual provide installation data for the technicians as well.

TIP: It is assumed that all the privileges are enabled to view and access MAM features listed in the interface.

2.Introduction

Media Asset Management, broadly defined, refers to the system that manages and monitors the assets in a systematic
process. QUICKEDGE is a hybrid integrated Asset management and Archival system. It encompasses the ingestion of files,
logging and classification of media, transcoding and verification of media across the work-flow and ensuring data integrity
during this process using advanced algorithms. QuickEdge MAM is a fully web-based application.

2.1 Supported Browser

Chrome Browser Version 83 and above

2.2 Supported Screen Resolution

Best user experience of QUICKEDGE MAM can be found on screens with a resolution of 1280 X 720 or higher.

2.3 Supported Fonts

QuickEdge supports all Unicode fonts
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2.4 Remote control support

QuickEdge client supports remote working from any part of the world. A stable internet line of at least 5Mbps is required
the same. Please contact our support team for configuration of remote control of the client application along with the
recommended security settings for firewall, network router etc.

2.5 Redundancy and backup

QuickEdge standard edition and QuickEdge Enterprise edition have inbuilt high availability mode enabled. This enables both
the application and database to be deployed on at least 2 servers for redundancy and performance scalability. The
enterprise edition can scale upto 50 servers in a cluster mode.

3. User Interface

3.1 Different work areas in the user interface

Once you login to the QuickEdgeMAM Web Application home screen, the user interface can be visualized as divided into six
areas.

A. Favourites: Favourites tableau allows users to mark an everyday used folder as favourite which makes you easy
to find. Favourite folder appears in the Favourites list on the left menu. Favourites are account specific.
Favourites can be marked by the user. Eg: Folder can be marked as favourite, which makes it easy to access.

B. Bins: A shared directory accessible to other users. A user can have access to multiple Bins. Bins are used to
control user privileges. A user can have write privilege in a Bin but might not have the same in another bin

C. Library: All archived media is available in the library area.
D. Media browser: Detailed information of media is available in the media browser. Links to search and advanced

search are also available in the media browser. Media browser provides various views such as thumbnail view, list
view, search view for ease of media preview.
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E. Preview: Media preview is available in this window.
F. Information: Complete media information is displayed in this window

3.2 Ingest

Raw data obtained needs to be imported for immediate use or should be sent for storage. QuickEdge manages data from
Ingest to distribution.

Ingest is a media file with appropriate metadata attached. QuickEdgeMAM allows you to ingest media (File / Folder)
automatically in the background to your shared bin. List of tasks like (NotifyToQEA, Generate Lowres, Generate Thumbnail)
are attached to your shared bin to process media files.

User can Ingest files to any path in the QuickEdgeMAM application.

1. On login, Click on ‘username’ icon on extreme right-corner of home page
2. Click on ‘My Preferences’
3. Click on ‘Ingest’
4. Set ‘Ingest path’ providing the mounted path
5. Click ‘update to’ save changes
6. Go to the upload path and right-click

7. Click on Ingest from context-menu

8. Click File option to ingest a file

👉 NOTE: Contact your administrator for ingest share credentials.

👉NOTE: User should have the ingest privileges like upload file and create folder to perform any ingest from

QuickEdgeMAM application.
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3.2.1 Watch Folder

A folder or a bin which QuickEdge watches for any media changes.

3.2.2 Upload File

Upload feature allows you to upload media files directly into the bin. Right-click inside your bin and select 'Upload Files'
option to upload files within it.

3.3 Export from Adobe Plugin (Optional)

Prerequisites:
To use QEProPlugin users must launch the plugin and do the settings and configurations as described step-by-step as
below.

1. QuickEdgeMAM plugin login window open.

2. Set MAM server URL

3. Login with provided username and password.

👉 NOTE: It is understood that export settings are already set.

👉 NOTE: Contact your administrator for plugin login credentials

Users can export a file from the timeline from an export window using Placeholder ID OR Media Name. In the export window,

users can select the Placeholder ID / Media Name, Export Profiles and Source Range and click the ‘Export’ button. File will

be exported to the export path (set destination path).
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3.4 MAM Features

3.4.1 New Folder

Users can create a new folder within the bin. Right-click inside your bin and select new->Folder and save changes.

3.4.2 Rename Folder

Users can rename a folder, with a new name. Select a folder, Right-click on folder and click Rename option

3.4.3 Move to Trash, Restore

Users can delete a file/files from the bin. Select a file->right-click->click move to trash. Files will be moved to the trash
folder. Users can go to the trash folder and restore a file. File will be restored back to the place from where it was deleted.
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3.4.4 Bin Permissions

Bin permissions is the access permissions for the user. Users can be controlled with bin permissions which can be set
‘Read-Only’, ‘Read-Write’, ‘Full Control’ and ‘No Access’.

1. Read-only : Users can view the files inside the bin but cannot perform any action on the file.
2. Read-Write : Users can edit, archive, copy or move the files in the bin.
3. Full Control : Users will have full access to the file and can delete the file from the bin.

👉 NOTE: Contact your administrator for your bin permissions.

3.4.5 Privileges

Administrators can control the QuickEdgeMAM feature access to users granting the required privileges. The
workspace for the users will be limited based on the privileges they have been granted. Privileges are of types
Basic, MAM, Archival, Transcode & Advanced.
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3.4.6 Copy and paste

Users can select a file or folder and copy to another folder / sub-folder / bin. Users can paste a file or folder into another
folder / sub folder / bin.
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3.4.7 Cut and paste

Users can cut a  file or folder and paste  into another folder / sub-folder / bin.

3.4.8 Extract Metadata

Extract metadata allows the user to fetch all the metadata of a media file (Image,Audio,Video) from either Bins or Library.
Administrators can pre-define the custom metadata fields and extract data for the same fields. If profile based extraction
is enabled, data will be extracted automatically.

Example 1: If you set Album, Title, Year, Genre, Duration as the custom fields, then the user can extract the values for
these fields from the audio files.

11 | Page



👉 NOTE: Administrator should enable ‘Profile based extraction’ option for the bin from settings>Bins>Extract

metadata.

Example 2: Users can also extract the metadata by right clicking on a file (from bins or library) and selecting the extract
metadata option from the context menu (if profile based extraction is not enabled).
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3.4.9 File Comments

File comments allow users to add a comment to a file. Comment icon will be displayed at the end of the file. Users can
click on the comment icon to view / edit / delete a comment.

3.5 Tag Metadata and Archive

3.5.1 Archive

Archive is a process of moving data that is no longer actively used to a storage device for long term retention. Data that is
still important and needed for the future reference.
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Librarian add metadata to media in metadata manager

[Organize metadata like Filename, Category, Tags, Media and Frame metadata]

3.5.2 Metadata

Metadata is the ‘data that gives information about the other data’ [like Video/Audio/Image] file. Metadata can be created
manually or automatically and it contains more basic information like Title, Author, Description, created date, modified
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date, and file size.

A. MarkIn-MarkOut section
B. Browse Category
C. Media Description
D. Tags
E. Custom Metadata
F. Copyright
G. Frame Metadata

3.5.3 Archive with metadata

Users can right-click on a file from a shared directory/bin and select archive with 'metadata' option. Doing so, the user is
prompted to the metadata manager window. You can now select a category, tags, add media description and custom
metadata fields like ID, Title, Date, source, Media Number, Time Code and click the 'Archive' button to complete the archival
process. While doing archive, users can select the pool type, on selecting LTO Pool all the high-resolution contents will be
moved after scheduled time frame to LTO tape library for deep Archival purposes.
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3.5.4 Tag Metadata

Tag is a keyword or a term assigned to a piece of information. Users can tag metadata for a Video / Audio / Image from Bin
/ Library. In Bin, Users can tag metadata like Description, Category, Tag, Copyright and Frame description before archive. In
the Library, users can tag metadata for already archived files. Select a file, right-click and select Tag metadata. A)

3.5.5 Archive (Already tagged metadata)

Users can tag metadata and then archive. Users can first select the file and tag metadata from doc window (right frame)
as shown in tag metadata screenshot and then archive a file with archive option from the context menu as described in
below screenshot.
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3.5.6 Archive With Bulk Tag Metadata

Users can choose to archive with bulk tag medata. Here, multiple files can be archived tagging the same metadata at one
shot. On doing so, all individual files take the same metadata mapped to the category.

1. Select multiple files and right-click, select ‘Archive with bulk metadata’ option from context menu.
2. Enter metadata details and click archive
3. Files will be archived individually with the same metadata.
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3.5.7 Archive Folder

Users can choose to archive the complete folder which has files in it. It is like archiving files within a folder. While archive
users can choose the category. Archived folders will be found in the chosen category.
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3.5.8 Archive as Tar

Users can choose to archive a folder as tar. The selected folder with files inside will then be archived as a one tar file.
1. Select a folder with files inside, and right click on the folder.
2. Select ‘Archive as Tar’ from the context menu.
3. Archive as Tar window opens.
4. Enter all details and click the archive button.
5. Folder will be archived as one tar file.
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3.5.9 Archive as Package

‘Archive as package’ allows users to select multiple files and archive as one package or say group. While archiving users
can choose to tag metadata for individual files OR for a group.

1. Select multiple files and right click.
2. Select ‘Archive as Package’ from the context menu.
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3. ‘Archive as Package’ window opens.
4. User can view selected files under clipboard
5. Users can tag metadata for a single file or for a package.
6. Click archive
7. Files are archived to the mapped category as a package.

3.5.10 Archive and attach to(to already archived assets)

‘Archive and attach to’ allows users to attach a file (usually related file) to one or more (already archived) files from the
Library.

● Select the file and right click
● Select ‘Archive and attach to’ from the context menu.
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● Users can search or Select the file / files from the listed categories displayed in ‘Archive and attach to file’
window.

● Select the predefined link option which is at the bottom left of the page before archive.
● Click Archive

● Attached file can be seen under the already archived file with the attach icon in the category.
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3.5.11 Archive and update version (to already archived assets)

While archiving a file, users can update the already archived asset with option ‘Archive and update version’ from the
context menu. Already archived files will be replaced with new versions, with details found under properties.

1. Select the file and right click
2. Select ‘Archive and update version’ from the context menu.
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3. Users can search or Select the file / files from the listed categories displayed in the ‘Archive and update version’
window.

4. Click Archive
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5. Already Archived files will be updated with a new version and can be seen in the properties section.
6. Users can preview, Retrieve and download the versions from the properties section.

3.6 Manage Metadata

Users can manage metadata like  add/edit/delete  Categories, Tags, Custom metadata, metadata profiles and Right
management from the settings section.

3.6.1 Categories

Categories are customizable and can be added /Edited /Deleted as required from settings>Metadata>categories
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3.6.1.1 Create Categories

1. Click Settings from homepage
2. Select Metadata>Categories
3. Click on Library
4. Click create button to add as many categories as required
5. Click 'Add' to save categories
6. Click Settings>Users>user>Edit>Category Permissions
7. Give Full control to the library / any category
8. Save changes, to enable categories

3.6.2 Tags

Tag is a keyword or a term assigned to a piece of information. Tags are customizable and can be added /Edited / Deleted
from settings>Metadata>Tags.
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3.6.2.1 Create Tags

1. Click Settings from home page
2. Select Metadata>Tags
3. Click ‘Create’ button to add as many tags as required
4. Click 'Add' to save tags and enable under tags list

3.6.3 Custom Metadata

Custom Metadata Types: Custom metadata feature allows you to customize metadata for all media files. Custom
metadata types like picklist, Plain text & date range provide users an option to add relevant information as keyword or
text.

Plain Text: Text field allows you to add content relevant to media while tagging metadata.
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Date Range: Date range allows users to set a date range option for media metadata.

Integer: Integer allows the user to set number and range.

Picklist: Picklist allows you to add keywords relevant to a media file, so that the user can choose that picklist keyword
while tagging metadata to a media file.

Global Custom Metadata

Administrators can predefine the global custom metadata fields for Image, Audio, Video and Generic media types.

3.6.4 Metadata Profiles

QuickEdge MAM provides the flexibility to customize and set Custom Metadata Profiles based on available custom
metadata. Users can choose added custom metadata fields and create profiles. Metadata profiles are mapped to
categories and will be displayed with lower order first in the metadata manager window. Users can fill in details of chosen
profile set metadata fields while tagging metadata to any media file.
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3.6.5 Copyright

Copyright allows the user to set the usage rights of the media file and the user will have the access to the file before the
date expires.
Users can set copyright type names with values. Users can use copyright types and set copyright for a file from the
metadata window. Users can edit and delete copyrights.

3.7 Retrieve

Retrieve is the process of retrieving media files. Users can either do complete retrieve or partial retrieve. Users can select
a file from the category (Eg: Nature and its components) and click the retrieve button on the top right corner of the page /
from the context menu. File will be retrieved to the set path

3.7.1 Retrieve from Library
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Users can retrieve files from the library section. Select category>Select File>Right-click>retrieve / click on retrieve button
at the top right corner of the home page.

3.7.2 Retrieve from Bins

Users can retrieve files from bins. Select bin>Select file File>Right-click>retrieve  / click on the retrieve button at the top
right corner of the home page.

3.7.3 Export to FTP Sites

Export to FTP feature allows users to export the file from source or Library to the FTP bin (Deployment Bin/Target Bin). FTP
destination bin should be created and added under bins->Deployment.
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3.7.4 Download

Download feature allows the user to download media files to your local system. Users can download files from a shared
directory/bin or from categories. Select bin or Library>Select File>Right-click>Download

3.7.5 Partial Retrieve

Partial retrieve allows users to truncate the file with markIn-markOut points and retrieve to the desired path/ folder. Users
can retrieve files from a shared directory/bin or from categories using ‘Retrieve as’ option from the context menu. Select
file>right-click>Retrieve as
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3.7.6 Import from Adobe Plugin

Users can import a file from the QuickEdgMAM application into the adobe plugin timeline.
Select a file from QuickEdgeMAM bin click Import button. File will be imported to the timeline. Editors can then edit the file
from the timeline.

3.7.7 Export to Outbox

Export to feature allows users to export the file from source and Library to the outbox.
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Exported files can be seen in the Outbox application as shown below. Users can search, preview and use the files from the
outbox application for further use.

3.8 Search

QuickEdge provides a large number of ways of searching and filtering clips. Types of search include simple and advanced
search. Users can choose and narrow down results.

3.8.1 Simple search

All archived files can be searched using a simple search method. Use the search field in the home page to filter clips shown
under categories to those containing keywords you type in. Archived files search works by searching on Slug name, Media
description, Custom Metadata, Frame description.

Auto Suggestion:
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During search, the auto suggestion feature makes the search experience easy by auto suggesting the related keywords. On
typing the keyword, a list of related suggestions will be displayed as in screenshot.

3.8.2 Phrase search (Exact keyword search)

Phrase search in QuickEdge allows users to filter audio/images/documents/videos based on the exact keyword matched
from shared directory/bin and archived files. Filtered results are displayed with keyword highlights.

3.8.3 Logical AND (&) Operator Search

AND operator is a search parameter used to narrow the focus of the search. Setting AND operator in search results
indicates that search results must be displayed including both words on either side of the operator

Eg: Search line: Modi & Rahul

3.8.4 Advanced search (Tags, Custom metadata)

Advanced search allows you by choosing the filters like Tags, Category, Custom Metadata and many more from the library.
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Tags: Users can search media filtering by tags. Search results are fetched based on given tag name

Category: User can search media files filtering by categories and sub categories filter or metadata profiles.

Results displayed are refined based on selected category

Custom Metadata: Users can search media files based on  custom metadata fields like PickList, Text and many more.

3.8.5 Geographical(Geo) Tag Search

Users can search extracted GPSLongitude and GPSLatitude of a place. Further to, User can narrow down the search based
on distance in meters within that longitude and latitude. Users can do an advanced search of a location.

3.8.6 Content search in document

Users can search content from document picking a keyword from the document. Searched files display keyword highlight in
the content section.
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3.9 Reports

3.9.1 Archive report

Archive report represents the archived data by QuickEdge MAM users. Users can filter data based on users / Filename /
Date. Report includes data like Filename, size, archived date and archived location. Users can also download the archived
report for reference. Click on 3 dots below the profile picture to open reports.

3.9.2 Audit trail report

Audit trail report represents QuickEdge MAM usage track report by all users. Users can filter data based on user / User
group / Action / Date / Filename. Report includes data like Filename, size, archived date and archived location. Users can
also download the archived report for reference.
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3.9.3 Retrieve report

Retrieve report represents the retrieved data by QuickEdge MAM users. Users can filter data based on users / Filename /
Date. Report includes data like Filename, size, archived date and archived location. Users can also download the archived
report for reference.

3.9.4 Storage usage report

Storage report provides details of bin disk usage. Users can monitor the bin/disk space.

38 | Page



3.9.5 User quota usage report

User quota usage report represents usage space of each user.

3.10 Tools

3.10.1 Duplicate asset detection

Users can view duplicate assets in different paths differentiated with color display for both source and archive assets.
Users can delete the duplicate assets using the delete option at the end of the path.
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3.10.2 Subtitle Tool

Subtitle is a translation seen at the bottom of the screen of the playing video / audio. Subtitle tool allows users to
markIn-markOut points for the playing audio / video sections / complete file. User has to place the SRT file in the same
directory as that of the original file and include a subtitle track in the player.
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3.10.3 Review Tool

Review tool allows users to send the media clip for review to other users. Other users can mark points / sections and
update the review.Updated review is received by users under the ‘REVIEW’ section.
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3.11 Sharing

3.11.1 Asset sharing

Users can share assets to other users & to group. Shared assets will be found in a user specific shared folder under
favourites. Every incoming new share will be notified to users with NEW status.

Select File>right-click>share>users/group.
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3.11.2 Sharing Via Email

Users can share assets via email. Users can select multiple emails and share assets.

Select File>right-click>share>Email.
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3.11.3 Sharing Via Chat

Users can share assets via chat. Users can select multiple users and enable the ‘Notify Via Chat’ option. Assets will be
shared to selected users in their chat window. Select File>right-click>share>Users>Notify via chat.

3.13 Chats

QuickEdge MAM application users can chat with other online users using chat feature. Users can text/reply through chats.
Users can edit and share media through chat.
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Users can search media files from their location system and upload or search from the bins and share through chat.
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3.1.4 Migration (Optional)

Need to add migration app

3.1.5 HSM Integration (Optional)

To integrate HSM with QuickEdgeMAM, follow below steps:
1. Create source asset bin, retrieve bin, proxy bin and cache bin in QuickEdgeMAM with the same bin id and

credentials as present in HSM.
2. Create cache bin in QuickEdgeMAM as the only archive bin in read only mode.
3. Attach HSM proxy bin and tasks to Cache archive bin.
4. Disable polling, MoveToArchivedTrash & Auto Archive (If enabled) for HSM source asset bins.
5. HSM pools will be synced to MAM, map categories to respective pool
6. Set ENABLE_HSM_OPERATIONS=true in mam_config.py to enable hsm configurations in QuickEdgeMAM.

[sudo vi/opt/etc/mam_config.py ]
1. Go to Settings>HSM, Enable HSM and provide details like HSM Web Service IP, Port & HSM Vendor and save.
2. Add "/opt/MediaWorker1.X/HSM/hsm_job_poller.py" to Mediaworker supervisor.

sudo vi /opt/MediaWorker1.X/supervisor/supervisord.conf
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3. Add "/opt/MediaWorker1.X/HSM/hsm_device_and_container_updater.py" to crontab to sync Disk and
Tape ids to QuickEdgeMAM.

sudo crontab -e (Add below line to sync archived devices in every 3 hours)
0 */3 * * * python /opt/MediaWorker1.X/HSM/hsm_device_and_container_updater.py

4. To sync all archived assets: Set SYNC_ALL_ASSETS = True, inside hsm_device_and_container_updater.py script
and run python /opt/MediaWorker1.X/HSM/hsm_device_and_container_updater.py

5. To cleanup one month old jobs: Add "/opt/MediaWorker1.X/HSM/remove_hsm_jobs.py" to crontab

sudo crontab -e (Add below line to cleanup old jobs on every Saturday at 11 PM)
0 23 * * 6 python /opt/MediaWorker1.X/HSM/remove_hsm_jobs.py

6. Restart Mediaworker supervisor
7. Start / Restart HSM Services manually

➢ Open Task Manager, in services select the HSM service, Right click on the service and select Open Services
➢ Search for HSM service from service window and right click and select Properties
➢ Select Log On and select This account option, give the correct user , password and confirm the password, give

'apply' and 'ok'.
➢ Start HSM service.
➢ Need to do the above steps for all services which are not running.

3.1.6 NLE PLUGIN
NLE Plugin allows the user to browse content in the Client systems and allows low resolution proxy to edit in place and
then export the file to the export path. Before editing and export users can double click on the file and preview the file. File
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will be played if lowres exist. User can also preview file in native player enabling the option from
Plugin>Settings>System>Native Player Preview

Remote Config workflow allows users to access the remote render application. The export file will be rendered in remote
render application and export to the outbox or set export path.
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